User defined aliases for Bors commands

I've had some feedback from users that bors r+ is hard to use and remember. They have asked for something like bors merge or bors test. I agree that r+ is inscrutable unless you love Bors.

I was thinking I could create a list of aliases for commands in the bors.toml file, so as to avoid polluting the bors codebase with piles of aliases.

What do people think of this idea?

I'd almost rather just add bors merge as a built-in alias and call it good.

The problem with project-specific configuration, even though I know we can't avoid it entirely, is that it makes it harder for maintainers that work on more than one bors-based project. I've already seen people trip over it because they simultaneously work on homu-based projects and bors-based projects, and the differences between them are really minor. Having bors-ng based projects inconsistent with each other would be even more annoying.

1 Like

Strong +1 here for adding "merge" as an alias for "r+" and "merge=foo" as an alias for "r=foo". That feels to me like a good match with "try" and "retry" as full words, too.

1 Like

I agree. One of the nice things about bors-ng is how consistent the user interface is across different projects.

I think that bors merge as a built-in alias for bors r+ is a good idea!

Please see the following RFC: Allow `merge` as an alias for `r+`

Also see the following pull request, which implements the RFC:

1 Like

bors merge is now available as an alias for bors r+