Merging works but not trying


I'm using a self-hosted Bors installation which seems to work except that it always times out when running a Try. If I run a merge, I see the batch appear in the Bors dashboard and the check appear on the GitHub PR. But if I run a Try, the PR doesn't appear in the dashboard, the check doesn't appear on the PR, and eventually I get a Timed out message. However, the merge to trying occurs and the test runs on the merge are running.

There is only one file in this PR: bors.toml.

CleanShot 2022-04-23 at 09.42.53

Any suggestions?


The thing that’s stopping me from helping you is that there’s still missing information here.

Can you post the contents of your bors.toml file, as well as an excerpt of your GitHub actions YML file?

Thanks for replying!

Here is my bors.toml

status = [
  "Code style validations",
  "Validate client results",
  "Validate backend results",
  "Validate shared results",
  "Validate e2e results",
  "Validate and publish build results"

My workflows are kind of big and as you can see there are several of them, but here's the common finalization step all but two share:

    name: Validate ${{ inputs.package }} results
    runs-on: ubuntu-latest
      - name: Validation
        if: ${{ always() }}
          FAILED: ${{ steps.test-results.outputs.outcome == 'failure' }}
        run: |
          if [[ $FAILED == "true" ]]; then
            exit 1
            exit 0

Do any of your workflow steps have a condition other than ${{ always() }}?

Yes. Whole jobs and individual steps alike can be skipped depending on conditions. However, the finalization step ensures that no matter what happens in the workflow before it, you always come out on the other end with a success or failure status.

And like I said, though I haven't yet run it to completion because I'm trying to try it first, it seems to have no problem if you do bors merge and not bors try.

Date: 4/22/2022, 11:47:48 PM

Priority: 0

State: Canceled


Validate client results (Running)
Validate backend results (Running)
Validate shared results (Running)
Validate e2e results (Running)
Code style validations (Succeeded)
Validate and publish build results (Succeeded)
Pull Requests:


If I run try, that kind of message doesn't even come up in the History.

Yeah, I know that try runs don’t get the nice batching pages, but they do work.

If I can rule out the possibility of it being a skipped step, then we’ll log into postgresql to look at the table, since the dashboard page unfortunately doesn’t show try run info.

I assume this means it can't find the checks?

There’s a third column, not visible in your screenshot, called “state.” That one will definitely tell you what’s going on.

But for GitHub Actions, which do have a connected URL, if the URL isn’t there, then it’s probably not finding it.

Ok, I think I figured it out. It wanted the full check name, like Validate and publish test results / Validate e2e results instead of just Validate e2e results.

Thanks for your help!