Getting gfx-rs/gfx-mem set up


#1

Where is this “Sync pull requests” button exactly? We’ve recently moved another repo under gfx-rs org (gfx-mem), and bors doesn’t see it.


Reviewer permissions broken on moved repositories?
#2

In the dashboard, it should be showing up at the bottom of your repository’s page:

Make sure you’re actually a reviewer on the repository, or that button won’t show up.


#3

Heh, problem is that I don’t even see this repository listed by bors (https://github.com/gfx-rs/gfx-mem), so I can’t sync anything.


#4

From the looks of it, bors isn’t enabled on that repo (I can’t open it in the admin page, and you didn’t get a Permission Denied error when you tried to use it). Can you go into https://github.com/apps/bors and add it?


#5

Bors is enabled for the whole gfx-rs organization, so I’m not enabling this specific repo.


#6

Okay, I think I found the source of the problem.


#7

@kvark It should work now.

(After further looking, it wasn’t what I thought it was. In fact, I’m still not sure what went wrong here. I just manually went into the Erlang shell and added gfx-rs/gfx-mem).


#8

Thanks for resolving the problem, and for moving the topic out of the old one!
I wish we knew what the problem really was though, I feel that it wasn’t the last time we see it.


#9

Heads up! So, as sort of expected, we are seeing the same problem on another project added to the org: https://github.com/gfx-rs/wgpu-native/pull/3#pullrequestreview-155753327
The issue is still there.


#10

Luckily, I actually have a solution this time. Bors now has background syncing, and it can just kick off a job whenever a repository gets renamed or moved.

When I tried manually running it, bors was trying to sync another repository before it synced yours, and that repository was blocked by GitHub for violating their ToS. For some reason, when GitHub blocks a repository, they don’t uninstall it, but they do serve up a 403 whenever you try to get a list of open PRs.


#11

@kvark Okay, it’s added now.


#12