Bors stuck in "running", never finishing jobs

I've recently been trying to set up bors with our public github repo ( GitHub - itchysats/10101: The world needs more Lightning!) against the public bors instance and am unable to make it work - it times out on all jobs. We are already using bors on another repo in the same org, and it works there without any issues ( GitHub - itchysats/10101: The world needs more Lightning!) . I took the configuration from the previous repo, and most of the GH actions were copied too.

Bors responds to commands (including r+) , but all runs end with statuses stuck in Running, until the timeout is reached.

bors output:

Date: 25/10/2022, 1:50:38 pm

Priority: 0

State: Failed


    CI (Running)
    formatting (Running)
    lint-commits (Running)

I tried doublechecking the names of the actions, and even went on to use some "meta-action" that just passes the summary of the run to bors; all with no avail.
Also tried disabling / enabling bors in the repository.

The only thing difference in the new repo is that it uses main as the default branch, and perhaps the digit-only name - none of these should be an issue I would assume.

Is there any way I could add more debugging output or something to try to nail down the issue?

You need to enable GitHub Actions on the staging and trying branches.

1 Like