Bors responding to ping, but not try or r+


Following on from, we are still having issues with bors. bors ping works, but not try or r+.

I've tried totally uninstalling bors and reinstalling it again, and I also tried re-raising the troublesome PR after that.

Here's a PR where we are experiencing the issue:

Clicking "details" next to the bors check takes us to a page which says: "Page not found".

In the bors log, there are crashes like:

body: "{\"message\":\"Resource not accessible by integration\",\"documentation_url\":\"\"}".

It's not clear if this is still to do with workflow permissions. We had, and accepted, a notification of the new permission before I reinstalled bors. Presumably reinstallation would have granted the new permission.

Looking at the apps permissions in our organisation's settings, we see:

No mention of workflow...

Something seems wrong. Any ideas?


Your pull request modifies the following file: .github/workflows/ci.yml.

This is a GitHub Actions workflow file.

Bors is a GitHub App.

GitHub Apps are not allowed to modify GitHub Actions workflow files under any circumstances.

If you need to modify a GitHub Actions workflow file, you will need to merge that pull request manually.

Ah, I see! Thanks so much.

I just killed upstream's .github dir and we are away!

It would be nice if bors could be a little more communicative with what is going on. For example it could say "Sorry, I can't do that: there's a change to a github action file .github/workflows/ci.yml".

I also notice that bors doesn't acknowledge "bors try-". It would be nice if it did (didn't it used to say "cancelled"?).


I tried adding the GitHub Actions permission to the bors app. Any idea if it would help?

We got a notification about a new permission a few days back and we accepted it, however, it didn't seem to help.

If @DilumAluthge's comment above is correct, it sounds like there's no permission you could have added to fix it.

GitHub Apps are not allowed to modify GitHub Actions workflow files under any circumstances.

1 Like

Yeah, I went ahead and remove the permission, since it didn't seem to help.

It does not seem to help. I also accepted the new permission on the repository, but bors still hung on a batch containing a pull request that modified a Github actions script.

It would be nice if bors could treat that as a failure for one specific pull request from the batch, retrying other as if the tests failed. Currently, the situation isn't documented well: You only see that bors says that the pull request is "Pending — Waiting in queue" (see e.g. ddnet/ddnet#2188).

@notriddle would it be possible to make bors comment on the PR with some human-readable message when something goes wrong?

Sure, it would be doable.

1 Like