Bors seems to not respond for about 3h now, judging by Refactor the Configuration by sebtomba · Pull Request #2248 · rchain/rchain · GitHub. We've observed Crash-es in the dashboard ( after seeing bors failures in

Let me know if you need a paste of the logs (I'd paste them, but am not sure how sensitive they are).

Thanks in advance for all the help! :slight_smile:


Try again?

Seems to work again, thx!

What was the issue? Is there anything we can do in the future to fix it without bothering you? :slight_smile:

1 Like

AFAICT, you didn’t do anything wrong. This error means that there’s a problem with bors, which is apparently trying to use an access token incorrectly. GitHub Apps have a root credential (the “private key”) which they use to make signed requests for repository-specific access tokens. The private key rarely changes, while the access tokens are only supposed to last for an hour. Either it failed to expire it, or it simply tried to use one that belong to a different repository.

I restarted it, thus clearing the cache entirely. Obviously, this is just a workaround, but I’m not sure what the proper fix is. If I see the same error happen more often, I’ll be better able to diagnose it.

1 Like